OBD Diagnose am Z3

Technische Fragen & Infos rund um den BMW Z3 roadster/coupe
(Motor, Getriebe, Auspuff, Motorelektronik, Elektrik, OBD, Chiptuning, Kühler, Kupplung, Schaltung, usw.)
Forumsregeln
Off-Topic sollte in den Fachforen vermieden werden.

Re: OBD Diagnose am Z3

Beitragvon mikexxl » 28.12.2021 18:13

Moin,
OldsCool hat geschrieben:Sicher? 98er müsste auf jeden Fall schon K-Bus haben :? Zumindest mit einem M44 hab ich mich darüber schon unterhalten wenn mich nicht alles täuscht...

Gruß Steffen


Nö, nicht sicher. Da steht 1.8, Bj 98, kann dann nur der M43 sein, oder?

Trotzdem egal, falsche Diag-SW.

Mehr als anbieten kann man es nicht.

Viele Grüße aus der Lüneburger Heide
Michael
mikexxl
Benutzer
 
9 Jahre Mitgliedschaft9 Jahre Mitgliedschaft9 Jahre Mitgliedschaft9 Jahre Mitgliedschaft9 Jahre Mitgliedschaft9 Jahre Mitgliedschaft9 Jahre Mitgliedschaft9 Jahre Mitgliedschaft9 Jahre Mitgliedschaft
 
Alter: 57
Beiträge: 254
Themen: 28
Bilder: 9
Registriert: 31.05.2015 18:33
Wohnort: 29649 Wietzendorf

Z3 roadster 2.8 (06/1997)

   



  

Re: OBD Diagnose am Z3

Beitragvon OldsCool » 28.12.2021 21:51

Ja klar, der 1.8 ist der M43. Ich meine nur ich hätte auch schon einen 97er M44 (1.9) per K-line diagnostiziert. Das müsste der 1.8er dann auch können. Ich meine (!), dass die ganz frühen Baujahre (95/96?) nur ADS haben. Bin aber beim VFL nie so ganz bibelfest. Da fehlt halt die persönliche Erfahrung.
Wer im Raum Memmingen Diagnose braucht kann sich gern melden, dann probieren wir das aus :2thumpsup:

Gruß Steffen
Benutzeravatar
OldsCool
Benutzer

Themenstarter
 
5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft
 
Alter: 44
Beiträge: 5210
Themen: 42
Bilder: 7
Registriert: 05.06.2019 14:08
Wohnort: Unterallgäu

Z3 roadster 1.9i (03/1999)

   


Z3 roadster 2.8 (01/2000)

   



  

Re: OBD Diagnose am Z3

Beitragvon Maxmuc » 18.07.2023 13:06

Hallo zusammen,

vielen Dank erstmal dem TE für diese Erläuterungen, massiv hilfreich! Das ist mein erster Post hier im Forum (also ein freundliches Hallo in die Runde) nachdem ich schon über ein Jahr mitlese und fleißig die Themensuche verwende ;) - ihr habt mir bei der Restaurierung meiner Zetti-Rostlaube schon unglaublich weitergeholfen, vielen Dank!

Nun komme ich aber bei der Diagnoseverbindung zur ZKE nicht weiter und grabe daher diesen alten Thread nochmal aus… ich verwende die bekannten BMW Diagnoseprogramme (sowohl alt als auch neu) und das funktioniert mit K+DCAN Interface soweit auch gut (bei meinem E39 und bei der Verbindung zur DME des Zetti). Nur die ZKE (GM IV HIGH, HW 1.5, SW 1.6 im 3.0i von 05/2001) antwortet nicht. Habe jetzt alles mit Multimeter durchgemessen: PIN 20 „OBD I“-Buchse zu PIN 11 am schwarzen Stecker des GM hat Durchgang und keinen Masseschluss, PIN 17+20 (bzw. 7+8) sind gebrückt. Was allerdings auffällt: auf PIN 17 liegen gegen Masse 11,7 V an, während es bei PIN 20 nur 9,9 V sind. Und das unabhängig davon, ob das GM angeschlossen ist oder nicht. Habe auch bereits ein anderes, baugleiches GM ausprobiert, gleiches Ergebnis. Was mir noch aufgefallen ist, aber weiß nicht ob es was zu bedeuten hat: wenn ich die Batterie abklemme und die Spannung PIN 17 und 20 gegen Masse Messe, ist PIN 17 sofort bei 0,0V, während die Spannung auf PIN 20 nur langsam abfällt. Später messe ich bei PIN 20 gegen Masse zunächst einen großen Widerstand im Megaohm-Bereich, der dann während der Messung abfällt bis auf etwa 110 Kiloohm und dann wieder langsam steigt (ca. 0,5 KOhm / Sek.).

Ich vermute, dass irgendwo auf der restlichen TXD II Leitung ein Fehler liegt, wodurch die Spannung abfällt und das Interface bzw. die Software die Signale nicht mehr richtig verarbeiten kann. (Es wird „zu leise“ gezupft?! Keine Ahnung…)

Falls es eine Rolle spielt: mit der DWA habe ich insoweit Probleme, dass die LED beim Abschließen einen Fehler signalisiert (schnelles Blinken) und die Innenraumüberwachung nicht funktioniert. Habe das Innenraumradarmodul bereits ausgetauscht, keine Veränderung. Alle Türkontakte sowie Kofferraum habe ich geprüft - sind iO. Haubenkontakt war nicht iO, habe ich abgesteckt, ebenso wie Radiokontakt. Neigungssensor funktioniert.

Vielleicht hat ja jemand einen Tipp, wie ich am besten bei der Fehlersuche fortfahren sollte?! Das wäre klasse!

Euch weiterhin allzeit gute Fahrt und frohes Schrauben!

Der Max
Maxmuc
Benutzer
 
2 Jahre Mitgliedschaft2 Jahre Mitgliedschaft
 
Alter: 38
Beiträge: 9
Bilder: 4
Registriert: 11.03.2022 01:44
Wohnort: München

Z3 roadster 3.0i (05/2001)

   
  

Re: OBD Diagnose am Z3

Beitragvon OldsCool » 18.07.2023 16:50

Servus Max!

Das Thema ZKE ist ein bisschen undurchsichtig. Bei mir klappt das mit dem K-Line-Kabel auch nicht immer, eine Systematik habe ich allerdings noch nicht erkennen können :? Hast Du es mal bei laufendem Motor probiert?
Eigentlich sollte es mit einem K-Line Interface funktionieren, allerdings besitzt die ZKE auch eine RXD-Verbindung, was normalerweise auf ADS-Protokoll schließen lässt. Trotzdem bin ich mir recht sicher, dass ich mit meinem alten K-Line-Interface auch schon drauf war... hmm. Müsste ich nochmal verifizieren.
Möglicherweise ist dein K-D-CAN allerdings zu neu und hat gar keinen RXD mehr. Das könnte auch ein Grund sein.
Hast Du außerdem mal alle ZKE-Varianten in der Auswahl unter E36/Karosserie ausprobiert?
Kommst Du denn auf andere Steuergeräte? (Airbag, ABS/DSC,...)
Damit könnte man ausschließen dass es an der Diagnoseverbindung liegt.

Die Spannungs-/Widerstandswerte sind wenig aussagekräftig. Du misst da mitten in eine elektronische Schaltung mit Widerständen, Transitoren etc. hinein. Da kommt in der Regel nichts sinnvolles dabei heraus. Nur 0V sollten nicht rauskommen, denn die Busleitung muss eigentlich immer Highpegel (nominal 12V) haben.
Für das konkrete Problem mit der DWA ist ein eigener Beitrag sinnvoll.

Gruß Steffen
Benutzeravatar
OldsCool
Benutzer

Themenstarter
 
5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft
 
Alter: 44
Beiträge: 5210
Themen: 42
Bilder: 7
Registriert: 05.06.2019 14:08
Wohnort: Unterallgäu

Z3 roadster 1.9i (03/1999)

   


Z3 roadster 2.8 (01/2000)

   



  

Re: OBD Diagnose am Z3

Beitragvon Maxmuc » 19.07.2023 08:35

Hi Steffen,

Danke für den Tipp mit der RXD Leitung, die hatte ich gestern auch noch im WDS entdeckt und auch gleich durchgemessen. Da kommt jedenfalls auf PIN15 was an. Ob der allerdings von meinem Interface überhaupt gelesen wird, muss ich mal nachforschen gehen. Hatte gehofft, dass ich auch dem Problem mit der DWA auf die Schliche komme, wenn ich erstmal die Verbindung zur ZKE habe.

Also ist es nicht so simpel, dass der Spannungswert (habe auch das nochmal gemessen: ins GM IV gehen 12V rein, es kommen dann aber an PIN 11 und 9 nur noch 9,x V heraus) darauf hindeutet, dass eben der Pull-Up Widerstand nicht tut was er soll? Aber der ist vermutlich auch irgendwo in die Platine integriert, sodass man dann das ganze Grundmodul vergessen kann?

Zum ADS-Protokoll: dafür bräuchte man dann lediglich ein anderes Interface, richtig? Kannst du da eines empfehlen? Falls es sowas noch gibt…

Grüße
Max
Maxmuc
Benutzer
 
2 Jahre Mitgliedschaft2 Jahre Mitgliedschaft
 
Alter: 38
Beiträge: 9
Bilder: 4
Registriert: 11.03.2022 01:44
Wohnort: München

Z3 roadster 3.0i (05/2001)

   
  

Re: OBD Diagnose am Z3

Beitragvon OldsCool » 19.07.2023 08:46

Ich benutze nur noch den modifizierten Elm327 Bluetooth Adapter von Ulrich Holeschak. Der kann ADS, K-LINE und D-CAN und alles über Bluetooth. Dafür muss der Laptop natürlich Bluetooth haben.

Ansonsten ist das ADS Interface von Doit Auto tauglich. Als Elektronikbastler kann man sich aber auch selbst ein ADS-Interface aus ein paar Widerständen und Transistoren bauen und in den OBD1-Stecker integrieren. Dafür braucht der Laptop dann eine echte Serielle Schnittstelle (oder man nutzt wieder die E*di*ab*asLib von Holeschak, die kann auch USB Adapter).
Die mit Abstand günstigste Lösung (neben Selbstbau) ist aber nach wie vor der oben erwähnte Bluetooth - Adapter.

Gruß Steffen
Dateianhänge
IMG_20230128_221721_edit_575738390137146_copy_1459x1094_1.jpg
DIY ADS Adapter
Benutzeravatar
OldsCool
Benutzer

Themenstarter
 
5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft
 
Alter: 44
Beiträge: 5210
Themen: 42
Bilder: 7
Registriert: 05.06.2019 14:08
Wohnort: Unterallgäu

Z3 roadster 1.9i (03/1999)

   


Z3 roadster 2.8 (01/2000)

   



  

Re: OBD Diagnose am Z3

Beitragvon spaddel » 29.08.2023 22:39

Hallo zusammen,

auch ich muss diesen Thread noch mal hervorholen. Ich bin ebenfalls auf der Suche nach einem Kabel (OBD2 und OBD1) zum Löschen des Fehlerspeichers bei meinem 2,8 Coupe von 1999. Das gute Stück hat die runde und die OBD2 Diagnosebuchse.

Mir geht es primär darum, den Fehlerspeicher des Motors, Abgassystem usw. zu löschen. Ich hatte bereits testweise ein Kabel von einem Freund hier, mit dem es nicht funktionierte. Der Vorbesitzer jedoch hatte ein Kabel, welches funktionierte, den kann ich aber nicht mehr erreichen.

Als Software verwende ich übrigens die Standard BMW Software mit I.

Danke und Gruß
Spaddel
spaddel
Benutzer
 
Beiträge: 2
Registriert: 29.08.2023 22:32

Z3 coupe 2.8 (02/1999)

   
  

Re: OBD Diagnose am Z3

Beitragvon OldsCool » 29.08.2023 23:35

Hallo Spaddel und herzlich willkommen!

Motor kannst du auch über die OBD2 auslesen. Als Kabel empfehle ich das Maxdia Diag1, falls du auch auf andere Steuergeräte willst in Verbindung mit einem Adapter auf die runde Dose im Motorraum.

Gruß Steffen
Benutzeravatar
OldsCool
Benutzer

Themenstarter
 
5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft5 Jahre Mitgliedschaft
 
Alter: 44
Beiträge: 5210
Themen: 42
Bilder: 7
Registriert: 05.06.2019 14:08
Wohnort: Unterallgäu

Z3 roadster 1.9i (03/1999)

   


Z3 roadster 2.8 (01/2000)

   



  

Re: OBD Diagnose am Z3

Beitragvon spaddel » 30.08.2023 10:09

Hallo Steffen,

vielen Dank für die schnelle Antwort. Über das Kabel bin ich bei meiner Recherche auch schon gestolpert.

Gruß
CD
spaddel
Benutzer
 
Beiträge: 2
Registriert: 29.08.2023 22:32

Z3 coupe 2.8 (02/1999)

   
  

Re: OBD Diagnose am Z3

Beitragvon Maxmuc » 19.09.2023 17:01

Hallo zusammen,

ich habe mir zwischenzeitlich das ELM327-Bluetooth Interface mit besorgt. Da funktioniert das Auslesen von DME auch wie bisher problemlos nur an das GM komme ich nach wie vor nicht. Die Verbindung zum ABS-DSC SG kann ich herstellen, also sollte die Diagnoseleitung an sich in Ordnung sein. Habe wie gesagt zwei identische GM IV hier und mit keinem kann ich eine Verbindung aufbauen.

Any ideas?

VG
Max
Maxmuc
Benutzer
 
2 Jahre Mitgliedschaft2 Jahre Mitgliedschaft
 
Alter: 38
Beiträge: 9
Bilder: 4
Registriert: 11.03.2022 01:44
Wohnort: München

Z3 roadster 3.0i (05/2001)

   
  

VorherigeNächste

  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag

Zurück zu Technik Antrieb



Wer ist online?

Mitglieder in diesem Forum: CommonCrawl [Bot] und 2 Gäste

x